Hack Tools

Trity – An Advanced Pentesting Framework from Vulnerability Testing to Cryptography

Trity is an advanced pentesting framework dedicated to everything from vulnerability testing to cryptography.

Installation & Usage

In order to install this program, it is crucial that you are on a Linux-based distro, preferably Kali-Linux or BackBox.
First, git clone.

git clone https://github.com/toxic-ig/Trity.git

Change directory, and then run the installer script (Must be root or have superuser permissions):

cd path/Trity
sudo python install.py

The install.py script will install of the necessary dependencies for you. Other platforms will be supported in the future.
Once finished, execute with:

trity
“If you get import errors while installing Trity in Linux distributions such as ImportError: No module named mechanize

Install mechanize from apt-get.”

sudo apt-get install python-mechanize

FAQ

What if I get ImportError: no module named x

Make sure you have Internet and try manually installing it by executing: pip install x (whatever x is)

Will Trity work on Windows?

No

Will Trity work on Mac OSX

I am not sure because there is no way for me to test it, but if someone would like to and told me the results I would greatly appreciate it 🙂 Except that you would have to install the modules manually.

Issues?

If you have any issues regarding the source code of this framework, as well as any errors you have encountered, please contact me at

Xmpp: toxic-ig@exploit.im
Email: toxicnull@gmail.com
Instagram: @_t0x1c
Twitter: @toxicnull
Kik: toxicnull
Discord: #9073

 
CREDITS: toxic-ig
DOWNLOAD Trity